Author Topic: Do I need VC+++ 2005?  (Read 4032 times)

Frank Lindberg

  • Hero Member
  • *****
  • Posts: 749
Do I need VC+++ 2005?
« on: November 19, 2012, 08:47:30 pm »
Hi,

I just saw in my add/remove programs folder that I have many VC++ from 2005 up to 2012. My question is now, do I need those from 2005 and how far can I delete them up to?
VA. Senior Captain Frank Lindberg
"United we stand and divided we fall"
My PC spec: MS Win10 pro 64 bit - Intel Core i9-9900K CPU @ OC to 5.0 GHz - 16GB Ram - Geforce 2080TI 11GBVRAM - P3Dv5.1

Paul J

  • Newbie
  • *
  • Posts: 10
Re: Do I need VC+++ 2005?
« Reply #1 on: November 20, 2012, 01:05:22 am »
Don't delete any of them Lindberg! Each one of those is a specific (redistributable) version of the C++ programming language, and will be required by the application (or addon), that they were installed with.   ;)

All the Best,

pj

virtuali

  • Administrator
  • Hero Member
  • *****
  • Posts: 41582
    • VIRTUALI Sagl
Re: Do I need VC+++ 2005?
« Reply #2 on: November 20, 2012, 03:29:13 am »
FSX itself needs the VC++2005 runtimes so, so Simconnect and any other FSX addon out there because, even those that were made using VC++2008 runtimes (like PMDG) have a double dependency to both the 2005 (because the Simconnect every FSX addon links to requires is) and the 2008 runtimes. All our products requires the 2005 (SP1) runtimes and if you have the 2010 and 2012, surely some other application installed them.

So, basically, unless you are trying to troubleshoot a problem, if everything seems to work, don't touch them.

Frank Lindberg

  • Hero Member
  • *****
  • Posts: 749
Re: Do I need VC+++ 2005?
« Reply #3 on: November 20, 2012, 06:14:51 am »
ok, thx guys. It's just that my fsx is unstable  :-\ I get "fatal error" often. And yes I did tried the issue with the UIAutomationCore.dll. I run fsx as admin and run it in XP sp.2 mode. Any other idea? 

PS: See my pc spec. in my signature.
VA. Senior Captain Frank Lindberg
"United we stand and divided we fall"
My PC spec: MS Win10 pro 64 bit - Intel Core i9-9900K CPU @ OC to 5.0 GHz - 16GB Ram - Geforce 2080TI 11GBVRAM - P3Dv5.1

virtuali

  • Administrator
  • Hero Member
  • *****
  • Posts: 41582
    • VIRTUALI Sagl
Re: Do I need VC+++ 2005?
« Reply #4 on: November 20, 2012, 04:33:25 pm »
ok, thx guys. It's just that my fsx is unstable  :-\ I get "fatal error" often

Without knowing WHAT is crashing, it's not point meddling with the VC++ 2005 runtimes, so you need to check your Event Viewer to understand what crashed. If it's the G3D.DLL (most common crash in FSX), it's not related to the VC++ runtimes, that would be either a "runtime error" or an error in MSVCR80.DLL.


Quote
I run fsx as admin and run it in XP sp.2 mode. Any other idea?  

It's not a problem running FSX as admin, but turn off the XP SP2 mode, because it only creates problems.

However, instead of running FSX as Admin, the best setup is to install FSX in a folder outside C:\Program Files, so you won't run into any permission issues with non-Vista/Win7 compliant addons, without having to run As Admin, which might be a bit unsafe, since a potential malware running inside FSX (like a virus that attached to an FSX module) would be able to get complete access to your system. Instead, if you had FSX installed into C:\FSX, and ran FSX as a regular user, it wouldn't be able to do much damage, except on that folder.

Frank Lindberg

  • Hero Member
  • *****
  • Posts: 749
Re: Do I need VC+++ 2005?
« Reply #5 on: November 20, 2012, 05:54:47 pm »
Ok, thanks for your help Umberto  ;) My FSX is installed under X:\Program Files (x86)\Microsoft Games\Microsoft Flight Simulator X   :( So I have to reinstall everything?? damn... it take a half a week.
VA. Senior Captain Frank Lindberg
"United we stand and divided we fall"
My PC spec: MS Win10 pro 64 bit - Intel Core i9-9900K CPU @ OC to 5.0 GHz - 16GB Ram - Geforce 2080TI 11GBVRAM - P3Dv5.1

virtuali

  • Administrator
  • Hero Member
  • *****
  • Posts: 41582
    • VIRTUALI Sagl
Re: Do I need VC+++ 2005?
« Reply #6 on: November 20, 2012, 05:58:02 pm »
Ok, thanks for your help Umberto  ;) My FSX is installed under X:\Program Files (x86)\Microsoft Games\Microsoft Flight Simulator X   :( So I have to reinstall everything?? damn... it take a half a week.

Well, there's a another option. You can go into the FSX folder, and change the permissions settings to add your own user name with full control on that folder, so there will be no need to use Administrator mode to get read/write access to the FSX folder, this will be basically the same as installing FSX into a folder outside "Program Files".

Frank Lindberg

  • Hero Member
  • *****
  • Posts: 749
Re: Do I need VC+++ 2005?
« Reply #7 on: November 20, 2012, 06:47:40 pm »
Ok, thanks for your help Umberto  ;) My FSX is installed under X:\Program Files (x86)\Microsoft Games\Microsoft Flight Simulator X   :( So I have to reinstall everything?? damn... it take a half a week.

Well, there's a another option. You can go into the FSX folder, and change the permissions settings to add your own user name with full control on that folder, so there will be no need to use Administrator mode to get read/write access to the FSX folder, this will be basically the same as installing FSX into a folder outside "Program Files".

Yes I already did that  ;)  thanks again for your great support. I appreciate it.
VA. Senior Captain Frank Lindberg
"United we stand and divided we fall"
My PC spec: MS Win10 pro 64 bit - Intel Core i9-9900K CPU @ OC to 5.0 GHz - 16GB Ram - Geforce 2080TI 11GBVRAM - P3Dv5.1

Frank Lindberg

  • Hero Member
  • *****
  • Posts: 749
Re: Do I need VC+++ 2005?
« Reply #8 on: November 23, 2012, 09:47:41 pm »
What problems do you mean? like what?
« Last Edit: November 23, 2012, 09:48:17 pm by virtuali »
VA. Senior Captain Frank Lindberg
"United we stand and divided we fall"
My PC spec: MS Win10 pro 64 bit - Intel Core i9-9900K CPU @ OC to 5.0 GHz - 16GB Ram - Geforce 2080TI 11GBVRAM - P3Dv5.1

virtuali

  • Administrator
  • Hero Member
  • *****
  • Posts: 41582
    • VIRTUALI Sagl
Re: Do I need VC+++ 2005?
« Reply #9 on: November 23, 2012, 09:53:43 pm »
What problems do you mean? like what?

We had all kind of reports of weird stuff happening the XP Compatibility enabled, like objects disappearing until you get close, objects missing some parts, but also just crashes.

FSX doesn't need it, it's a fully compatible Vista/Windows7 app, if requires admin access, it's because some addons are not compliant, and try to write into the FSX folder itself that, being under C:\Program Files by default, can't be written without Admin account or turning off UAC.

None of our products needs this, they all write in the proper places as suggested by Microsoft, which are the %APPDATA% folders but, since many addon developers tell you to always run as Admin (because their products try to write in the wrong folder, the app folder itself), it might be needed in many cases OR you just grant to your own regular user name full access to the FSX folder, which is basically the same.

Frank Lindberg

  • Hero Member
  • *****
  • Posts: 749
Re: Do I need VC+++ 2005?
« Reply #10 on: November 23, 2012, 09:57:57 pm »
ok thanks.

I solved my fsx Fatal errors with UIAutomationCore.dll and removed the ENB. Now I can fly without CTD/fatal errors.
VA. Senior Captain Frank Lindberg
"United we stand and divided we fall"
My PC spec: MS Win10 pro 64 bit - Intel Core i9-9900K CPU @ OC to 5.0 GHz - 16GB Ram - Geforce 2080TI 11GBVRAM - P3Dv5.1