Author Topic: ORBX EGPH  (Read 1442 times)

yvesamuel

  • Full Member
  • ***
  • Posts: 151
ORBX EGPH
« on: August 16, 2021, 08:32:09 pm »
Hi,

I have a problem : I installed the airport normaly, copied the SODE folder in 12bpilot directory, have GSX level 2, but no jetways! (message "no jetways at this gate, and tried several)
What have I made wrong???

Thank for help
Yves from  ELLX

virtuali

  • Administrator
  • Hero Member
  • *****
  • Posts: 45960
    • VIRTUALI Sagl
Re: ORBX EGPH
« Reply #1 on: August 17, 2021, 04:32:00 pm »
I'm assuming that, with "copied the SODE folder", you mean this is a scenery that comes with an optional set of SODE jetways that must be installed manually ?

That doesn't seem a correct way to install because, just "copying a SODE folder" ( you don't say anything about its content, so I can't say if you installed it correctly ), it's not enough because, if the scenery originally came with default CTRL+J Jetways, to switch to a SODE configuration it would surely need an alternate AFCAD with NO jetways, otherwise you'll see double jetways.

Assuming you forgot to say you also copied this alternate AFCAD ( you haven't said anything about seeing double jetways, so I assume you don't see any ), you should then check if GSX is using it, which can be done by checking the name of the AFCAD in the GSX gate customization page.

If GSX is not reading the correct AFCAD, you can try the "Restart and rebuild the airport cache" from the Couatl Settings menu.

If GSX is still not reading the correct AFCAD after a cache rebuild, maybe there's another AFCAD in conflict which, again, will be listed by name in the the GSX gate customization page.

If, instead, GSX IS reading the correct file, than the GSX customization page should read "XML jetway" for each gate of that airport. HOWEVER, if you tried to customize that airport BEFORE installing the SODE jetways, you will have to remove the GSX .INI profile you made. Again, the GSX gate customization page will also tell you if GSX has loaded a custom .INI profile for that airport. If it has, and the profile was made BEFORE you switched to SODE jetways, you must remove it, either by removing the file or by pressing the "RESET" button after selecting the "Aiport" node on the left, which equals to select all gates and Reset all of them.

If, after you are sure GSX is reading the correct AFCAD, there's no custom GSX .INI profile in use, but you still don't see all jetways listed as "XML Jetways" in the GSX gate customization page, then the only possible explanation left is you copied the "SODE folder" in the wrong place. You can check if this is the case if SODE also can't see the jetways, from its own TAB+S menu.

If SODE see the jetways, but GSX doesn't, it might be due to the scenery developers using the wrong gate names for the SODE jetways. While it IS allowed to be "lazy" in naming for "just" SODE usage, when SODE is used together with GSX, the gate names must be EXACTLY as they are in the underlying AFCAD, which is the only way for SODE and GSX to communicate which jetway is associated with each gate. Some developers used non-standard names to present "friendly" names for the jetways, but SODE has a different way to do that, instead of using the gate name, which must be standard.

yvesamuel

  • Full Member
  • ***
  • Posts: 151
Re: ORBX EGPH
« Reply #2 on: August 18, 2021, 10:49:39 am »
Thank's Umberto for your reply.

I tested everything, and opened the xml file. The problem is there. Not all the gates have jetways. As I fly most of the time with big aircrafts, there is only one heavy gate with jetways...
I'll try to add the missing gates myself.

Have a good day
Yves