Author Topic: Setting XML File to OFF as per Cartyana File  (Read 1426 times)

jay907uk

  • Newbie
  • *
  • Posts: 44
Setting XML File to OFF as per Cartyana File
« on: May 02, 2021, 04:35:47 am »
Hi All,

I've noticed on some of the Files made by Cartyana he says about setting the XML File for stands or Jetways to OFF?

I've tried this several times with the EBBR from Justsim and UUWW Scenery from Justsim and the jetways just have a Red X?

1) What am I doing wrong?
2) What is the correct procedure to turn these XML Files to OFF? If I delete the relevant file then the jetways disappear completely?

I always follow his instructions that he has sent with the relevant airport, but it doesn't always work like he says.

Any help or advice gratefully appreciated.

I was tempted to try doing something like this myself, by following the Tutorials made by Cartaya but am not sure how easy I'd find it and if there is a set procedure to do each time for each airport.

Thanks

Jason

virtuali

  • Administrator
  • Hero Member
  • *****
  • Posts: 42991
    • VIRTUALI Sagl
Re: Setting XML File to OFF as per Cartyana File
« Reply #1 on: May 02, 2021, 12:12:49 pm »
I've noticed on some of the Files made by Cartyana he says about setting the XML File for stands or Jetways to OFF?

A Red X is a message from SODE, telling a scenery has a SODE XML file ACTIVE ( indicating you haven't disabled it ), but SODE can't find the SimObjects that are supposed to be created by it.

It doesn't have anything to do with GSX because, if GSX had a problem, you wouldn't see any Red X, since GSX creates its own jetways so, if they were missing or the GSX customization file called from specific models you don't have, you won't see a "Red X", but an error about a specific object name not being found from GSX.

If you disable the 3rd party scenery SODE XML file correctly, the only thing that is supposed to happen, is the SODE objects would just disappear. If you see the "Red X" it means the opposite: you haven't disabled the SODE XML file, but for some reason the objects that belong to that scenery can't be found, this is usually a problem with that scenery installation, but it's impossible to provide a generic suggestion, because each scenery has its ways to reinstall things, especially when SODE jetways are concerned, some products might have configuration utilities that switch between SODE or Standard jetways, but it's not a rule whether they also install/remove the related 3d models for the jetways too, they might or they might require reinstalling the scenery.

Of course, if you disable the SODE XML file, if the original SODE jetways are not installed ( this is the meaning of the Red Xs in SODE when the XML file is ACTIVE ), it won't be a problem anymore, since you are going to use the GSX ones anyway.

So, it seems your problem it's just you haven't removed or renamed the correct XML files for those sceneries. I guess Cartayna suggestion is to RENAME the XML file to .OFF ( = replace the .XML extension with .OFF extension ), instead of removing it, so it might be easier to get it back for any reason.

jay907uk

  • Newbie
  • *
  • Posts: 44
Re: Setting XML File to OFF as per Cartyana File
« Reply #2 on: May 06, 2021, 04:51:31 am »
Umberto,

Thanks for the detailed explanation. So I just need to delete .XML and have .OFF instead?.
I've always followed his instructions that he has included, but it doesn't always do what it's supposed to.

Maybe it might be beneficial for me to watch the you tube videos and try doing somethings myself with regards configuring GSX.
People make it look easy but I'm not 100% sure.

Thanks

Jason

virtuali

  • Administrator
  • Hero Member
  • *****
  • Posts: 42991
    • VIRTUALI Sagl
Re: Setting XML File to OFF as per Cartyana File
« Reply #3 on: May 07, 2021, 12:43:49 pm »
Thanks for the detailed explanation. So I just need to delete .XML and have .OFF instead?.

It's exactly the same. Renaming or deleting won't make any difference, it's just that by renaming, you can restore the original file more quickly, should you need to do that.