Author Topic: AI MIL_COMBAT problem  (Read 4950 times)

yerffej

  • Newbie
  • *
  • Posts: 14
AI MIL_COMBAT problem
« on: February 24, 2014, 06:45:39 pm »
Any AI airplane (including the FSX default F-18) with MIL











Any AI airplane (including the FSX default F-18) with MIL_COMBAT or MIL_CARGO as the atc_parking_type in it's .cfg file will not proceed to the runway. They will taxi to the T-8L runway entrance, hold to the wait time runs out, then disappear. I made default FSX F-18 & Captain Sim's C-130 FSX traffic files with Don Grrovestine's Ai Flight Planner when I discovered the problem. Are there any solutions? ???











Dave_YVR

  • Beta tester
  • Hero Member
  • *****
  • Posts: 801
Re: AI MIL_COMBAT problem
« Reply #1 on: February 24, 2014, 08:57:27 pm »
It's most likely a problem from using User Aircraft as AI. The FDE wasn't meant to be AI controlled. Use a proper AI model and you'll probably see better results. My Hickam is loaded and the traffic come and go as they should. C17's, C130's (all variants), F22's, KC135's, KC10's, C5's, and more.

yerffej

  • Newbie
  • *
  • Posts: 14
Re: AI MIL_COMBAT problem
« Reply #2 on: February 25, 2014, 11:55:51 pm »
I had deleted the atc_parking_type line from the .cfg file and the airplane shows up in a different parking area. And yes, then it does take off, but from a differnt runway. It seems to be something about the T-8L runway entrance.

Dave_YVR

  • Beta tester
  • Hero Member
  • *****
  • Posts: 801
Re: AI MIL_COMBAT problem
« Reply #3 on: February 26, 2014, 02:05:00 am »
 Ah, I see what the most probable issue is. In the default FSDT HNL afcad the holdshort node on T at 08L is too far from the runway which will produce erratic AI behavior. The AI engine treats the AI aircraft as never actually getting close enough to the runway to depart and therefore won't depart it.