FSDreamTeam forum
August 29, 2014, 12:56:39 PM *
Welcome, Guest. Please login or register.

Login with username, password and session length
News: KIAH has been released!
 
   Home   Help Login Register  
Pages: [1] 2 3 4
  Print  
Author Topic: GSX Not Working for me, messed up my newer FSDT Sceneries (KLAX, KDFW)  (Read 7699 times)
Smasher77th
Newbie
*
Posts: 21


« on: February 03, 2012, 06:58:14 AM »

I am so frustrated here. I didn't want to post immediately because I wanted to do a proper research on the forum and see if anyone already has my problem and if a solution has been provided.

This is my problem:
I first bought the KDFW and KLAS sceneries and installed them, and they've been working without any flaws, then I bought the KLAX and that too has performed flawlessly. Everything was fine until I bought GSX and OhareX yesterday. I installed them both, OhareX first, then GSX. I started FSX with one of the aerosoft airports (ENGM), and tried the ctrl + F12, nothng, so I disabled AES for that airport, thinking it might be the reason, nothing! I tried KLAX, and to my surprise, all textures (including runways and buildings) were gone! Same with KDFW! I checked KLAS and the buildings were gone, but the runways were intact, same with KORD, although at KORD, some buildings were still present, but not all. After reading everything I could find on the forums relating to this issue, I uninstalled everything, and started installing them one by one. (I already turned off my AV which is Microsoft Security Essentials, and I already excluded my entire FSX folder from scanning, but I went ahead and excluded the bglmanx and the couatl files, just in case)

I noticed that when I install KORD and KLAS, they work fine without any issues, all buildings and runways present. Even when I install the KLAX and KDFW, the previous two still remain intact, but for the KLAX and KDFW, all buildings are present, but no runway textures on both. As soon as I install either GSX or the Stand alone Addon manager, All buildings from all 4 airports disappear, but I still have the runways/taxiways at KLAS and KORD, and at KORD, I think I have some of the buildings but not all. I still see the addon manager and Couatl powered products on the menu, but when I click the 3 options on couatl (key mapping, restart couatl and ... (I forget), nothing happens. On the addon manager, it shows all five (including GSX) as installed and active. Also, I get the message to run couatl and addon manager, and I run and 'trust' them.

I read where one of the posters here was instructed to create the couatl.ini file, and I did that. Here is what I have in my log:

------------------------------------------------------------
connecting to SimConnect...
connected to FSX
bglmanx non ready yet, waiting.
connected to bglmanx
Loading addons
requesting AddOn list to bglmanx
bglmanx list contains 16 AddOn(s)
Loading addon ZurichX
Addon ZurichX not installed or missing one or more files, skipping
Loading addon OHareX
Addon OHareX loaded
Loading addon JFK
Addon JFK not installed or missing one or more files, skipping
Loading addon XPOI
Addon XPOI not installed or missing one or more files, skipping
Loading addon LSGG
Addon LSGG not installed or missing one or more files, skipping
Loading addon KLAS
Addon KLAS loaded
Loading addon KFLL
Addon KFLL not installed or missing one or more files, skipping
Loading addon PHNL
Addon PHNL not installed or missing one or more files, skipping
Loading addon KDFW
Addon KDFW loaded
Loading addon HAWAII1
Addon HAWAII1 not installed or missing one or more files, skipping
Loading addon HAWAII2
Addon HAWAII2 not installed or missing one or more files, skipping
Loading addon KLAX
Addon KLAX loaded
Addon ParkMe has been disabled by .ini file
Loading addon GSX

-------------------------------------------

I wonder why it doesn't say "Addon GSX loaded"

Any help is appreciated
« Last Edit: February 03, 2012, 10:05:09 AM by Smasher77th » Logged
virtuali
Administrator
Hero Member
*****
Posts: 16557



WWW
« Reply #1 on: February 03, 2012, 11:22:25 AM »

You can safely discount any possible problem with antivirus, etc. In that case, you would see nothing, no menu, let alone the ability to generate a log in the first place.

It would have been best if you posted the complete log file, without cutting anything, for example the first lines are surely missing, which lists date, time, the Couatl version number, etc.

Just as a shot, have you tried updating your AUDIO drivers ? GSX requires your audio drivers being OpenAL compliant, after loading all addons, it should have displayed informations about your audio card but, since you haven't posted the whole file, I'm not sure if there's something more or not.
Logged

kbutterfield
Newbie
*
Posts: 26


« Reply #2 on: February 03, 2012, 03:51:12 PM »

I have the exact same problem.

After installing GSXC andd the new add on manager, I know longer have any buildings at KJFK, KLAS or Flight Beams KSFO. I am missing the United satellite terminal at KORD.  I also have the demo for KLAX and KDFW and they have know buildings.

I have "Coatle powered products" menu with the 3 options but nothing happens when I click on any of the options.  Like the original poster here, I have followed every trouble shooting step in this post and every other post regarding lost buildings in this forum to no avail. I even tried to do a system restore to a point prior to installing GSX and that did not work.

Here is my complete log file. Nothing has been left out

couatl v2.0 (build 2290)
log started on Fri Feb 03 07:27:49 2012

connecting to SimConnect...
connected to FSX
bglmanx non ready yet, waiting.
connected to bglmanx
Loading addons
requesting AddOn list to bglmanx
bglmanx list contains 16 AddOn(s)
Loading addon ZurichX
Addon ZurichX not installed or missing one or more files, skipping
Loading addon OHareX
Addon OHareX loaded
Loading addon JFK
Addon JFK loaded
Loading addon XPOI
Addon XPOI not installed or missing one or more files, skipping
Loading addon LSGG
Addon LSGG not installed or missing one or more files, skipping
Loading addon KLAS
Addon KLAS loaded
Loading addon KFLL
Addon KFLL not installed or missing one or more files, skipping
Loading addon PHNL
Addon PHNL not installed or missing one or more files, skipping
Loading addon KDFW
Addon KDFW loaded
Loading addon HAWAII1
Addon HAWAII1 not installed or missing one or more files, skipping
Loading addon HAWAII2
Addon HAWAII2 not installed or missing one or more files, skipping
Loading addon KLAX
Addon KLAX loaded
Addon ParkMe has been disabled by .ini file
Loading addon GSX



Again, like the previous poster, it does not show GSX as loaded.

Prior to loading GSX, all my FS Dream and Flight Beam products were working perfectly.

Hopefully we can get this working. I miss my airports and I was so looking to forward to playing around with GSX.


I'm running Windows 7 with no anti-virus installed.



Kyle
[email protected]


* couatl.log.txt (1.1 KB - downloaded 71 times.)
Logged
Smasher77th
Newbie
*
Posts: 21


« Reply #3 on: February 03, 2012, 03:56:22 PM »

Sorry about the the cutting off of the beginning of the log. It was unintentional. Here is the complete log:

------------------------------------------------------
couatl v2.0 (build 2290)
log started on Fri Feb 03 09:43:53 2012

connecting to SimConnect...
connected to FSX
bglmanx non ready yet, waiting.
connected to bglmanx
Loading addons
requesting AddOn list to bglmanx
bglmanx list contains 16 AddOn(s)
Loading addon ZurichX
Addon ZurichX not installed or missing one or more files, skipping
Loading addon OHareX
Addon OHareX loaded
Loading addon JFK
Addon JFK not installed or missing one or more files, skipping
Loading addon XPOI
Addon XPOI not installed or missing one or more files, skipping
Loading addon LSGG
Addon LSGG not installed or missing one or more files, skipping
Loading addon KLAS
Addon KLAS loaded
Loading addon KFLL
Addon KFLL not installed or missing one or more files, skipping
Loading addon PHNL
Addon PHNL not installed or missing one or more files, skipping
Loading addon KDFW
Addon KDFW loaded
Loading addon HAWAII1
Addon HAWAII1 not installed or missing one or more files, skipping
Loading addon HAWAII2
Addon HAWAII2 not installed or missing one or more files, skipping
Loading addon KLAX
Addon KLAX loaded
Addon ParkMe has been disabled by .ini file
Loading addon GSX
-----------------------------------------------------------

That's the entire log. I'll try the audio drivers.
Logged
virtuali
Administrator
Hero Member
*****
Posts: 16557



WWW
« Reply #4 on: February 03, 2012, 03:56:44 PM »

I can only repeat what I've already wrote before:

You can safely discount any possible problem with antivirus, etc. In that case, you would see nothing, no menu, let alone the ability to generate a log in the first place.

Have you tried updating your AUDIO drivers ? GSX requires your audio drivers being OpenAL compliant, after loading all addons, it should have displayed informations about your audio card. It's possible that a missing/wrong driver has created a problem to it.
Logged

Smasher77th
Newbie
*
Posts: 21


« Reply #5 on: February 03, 2012, 04:28:57 PM »

I can only repeat what I've already wrote before:

You can safely discount any possible problem with antivirus, etc. In that case, you would see nothing, no menu, let alone the ability to generate a log in the first place.

Have you tried updating your AUDIO drivers ? GSX requires your audio drivers being OpenAL compliant, after loading all addons, it should have displayed informations about your audio card. It's possible that a missing/wrong driver has created a problem to it.

I just checked my audio drivers and they're up to date and working well. I have an onboard sound card and my Motherboard is Asus P6T Deluxe V2, and I'm running Windows 7 Ultimate x64. I believe it's OpenAL compliant. Moreover, I don't think the log is displaying everything. It doesn't say if GSX is loaded or failed to load, or skipped. Could someone with a working GSX please post their log, so we can compare?

Thanks in advance
Logged
virtuali
Administrator
Hero Member
*****
Posts: 16557



WWW
« Reply #6 on: February 03, 2012, 05:11:53 PM »

Moreover, I don't think the log is displaying everything. It doesn't say if GSX is loaded or failed to load, or skipped. Could someone with a working GSX please post their log, so we can compare?

I said the audio could be a problem for the very reason I obviously KNOW what a correct starting log should look like, after the "Loading addon GSX", the next line should be all the informations about your audio card and, immediately after the audio card informations, there should be a line saying "GSX addon loaded".

So, you are missing exactly that, as if your audio driver crashed or caused any other problem that made GSX waiting for it without going further.

Fact that your sound card "seems" to work well, doesn't mean everything it's ok, if your audio drivers don't support OpenAL, or their support for it is bugged, GSX will not work.

Try this file from Creative Labs, sometimes it's able to fix OpenAL problems:

http://connect.creativelabs.com/openal/Downloads/oalinst.zip
Logged

Smasher77th
Newbie
*
Posts: 21


« Reply #7 on: February 03, 2012, 06:45:15 PM »

Moreover, I don't think the log is displaying everything. It doesn't say if GSX is loaded or failed to load, or skipped. Could someone with a working GSX please post their log, so we can compare?

I said the audio could be a problem for the very reason I obviously KNOW what a correct starting log should look like, after the "Loading addon GSX", the next line should be all the informations about your audio card and, immediately after the audio card informations, there should be a line saying "GSX addon loaded".

So, you are missing exactly that, as if your audio driver crashed or caused any other problem that made GSX waiting for it without going further.

Fact that your sound card "seems" to work well, doesn't mean everything it's ok, if your audio drivers don't support OpenAL, or their support for it is bugged, GSX will not work.

Try this file from Creative Labs, sometimes it's able to fix OpenAL problems:

http://connect.creativelabs.com/openal/Downloads/oalinst.zip


I downloaded the file, reinstalled the standalone addon manager, and in each case I always did a reboot (even though I don't think that's necessary), and I still have the same problem:
______________________________________________
couatl v2.0 (build 2290)
log started on Fri Feb 03 12:25:55 2012

connecting to SimConnect...
connected to FSX
bglmanx non ready yet, waiting.
connected to bglmanx
Loading addons
requesting AddOn list to bglmanx
bglmanx list contains 16 AddOn(s)
Loading addon ZurichX
Addon ZurichX not installed or missing one or more files, skipping
Loading addon OHareX
Addon OHareX loaded
Loading addon JFK
Addon JFK not installed or missing one or more files, skipping
Loading addon XPOI
Addon XPOI not installed or missing one or more files, skipping
Loading addon LSGG
Addon LSGG not installed or missing one or more files, skipping
Loading addon KLAS
Addon KLAS loaded
Loading addon KFLL
Addon KFLL not installed or missing one or more files, skipping
Loading addon PHNL
Addon PHNL not installed or missing one or more files, skipping
Loading addon KDFW
Addon KDFW loaded
Loading addon HAWAII1
Addon HAWAII1 not installed or missing one or more files, skipping
Loading addon HAWAII2
Addon HAWAII2 not installed or missing one or more files, skipping
Loading addon KLAX
Addon KLAX loaded
Addon ParkMe has been disabled by .ini file
Loading addon GSX
______________________________________________
Logged
kbutterfield
Newbie
*
Posts: 26


« Reply #8 on: February 03, 2012, 07:21:30 PM »


Same results here. I've been working on this for 2 days now.I'm using a Sound Blaster X-Fi Titanium,latest driver version 2.17.8.  I've been searching all over the internet for possible solutions to the OpenAL issue to know avail.  I tried the above OpenAl fix file, but it didn't work. I'm ready to give up on GSX.  I just want my airport buildings back. I've tried everything from a uninstalling GSX and addon manager, reinstalling addon manager, system restore to a previous time. Nothing works to restore the buildings.

What else can I do to get the buildings back for KJKF, KORD, KLAS and KSFO?

Do I need to uninstall and reinstall all of them?


Kyle
Logged
virtuali
Administrator
Hero Member
*****
Posts: 16557



WWW
« Reply #9 on: February 03, 2012, 07:23:59 PM »

You just need to wait while we try to be sure it's *really* the sound card, for that we might need additional diagnostic. I'll get back to you.
Logged

kbutterfield
Newbie
*
Posts: 26


« Reply #10 on: February 03, 2012, 09:50:58 PM »

Update on trouble shooting the above problem.

I uninstalled GSX - still no buildings.

I re-installed ORD 2.0 and now I have buildings, but it loaded back the old add on manager menu with key mappings as the only option in the menu.  Key mapping now works.
 
Re-installed GSX exactly has posted. Buildings disappeared but I now have the new add on manager with the 3 options(none work) but no buildings.  Same log file results as above.

Installed the stand alone add on manager. No buildings with the same log file results above.

I wanted my buildings so I re-installed ORD 2.0 with GSX still installed.  Buildings are back, old add on manager menu with key mappings only but GSX does not work. See log file below.

I guess the new add on manager is not compatible with mine and others systems. I'm disapointed. I was looking forward to GSX.

Hopefully we can find a solution so I can enjoy GSX as others are.



couatl v2.0 (build 2290)
log started on Fri Feb 03 13:29:28 2012

connecting to SimConnect...
connected to FSX
bglmanx non ready yet, waiting.
connected to bglmanx
Loading addons
requesting AddOn list to bglmanx
bglmanx list contains 16 AddOn(s)
Loading addon ZurichX
Addon ZurichX not installed or missing one or more files, skipping
Loading addon OHareX
Addon OHareX loaded
Loading addon JFK
Addon JFK loaded
Loading addon XPOI
Addon XPOI not installed or missing one or more files, skipping
Loading addon LSGG
Addon LSGG not installed or missing one or more files, skipping
Loading addon KLAS
Addon KLAS loaded
Loading addon KFLL
Addon KFLL not installed or missing one or more files, skipping
Loading addon PHNL
Addon PHNL not installed or missing one or more files, skipping
Loading addon KDFW
Addon KDFW loaded
Loading addon HAWAII1
Addon HAWAII1 not installed or missing one or more files, skipping
Loading addon HAWAII2
Addon HAWAII2 not installed or missing one or more files, skipping
Loading addon KLAX
Addon KLAX loaded
Addon ParkMe has been disabled by .ini file
Loading addon GSX
Error: while loading addon GSX, traceback follows
Traceback (most recent call last):
  File "<string>", line 53, in loadAddons
  File "couatl\GSX\__init__.py", line 5, in <module>
  File "couatl\GSX\airportCustomization.py", line 6, in <module>
  File "couatl\GSX\parkingServices\__init__.py", line 1, in <module>
  File "couatl\GSX\parkingServices\followMe.py", line 10, in <module>
  File "couatl\common\engineNoiseEmitter.py", line 2, in <module>
  File "couatl\common\audioManager.py", line 65, in <module>
TypeError: 'bool' object is not callable
Loading addon ENBR
Addon ENBR not installed or missing one or more files, skipping
Loading addon KSFO
Addon KSFO loaded
Starting system monitors
Loading aircraft data from Airplanes\dhc8-q400_x
SharedMemInterface connected



Kyle B
Logged
virtuali
Administrator
Hero Member
*****
Posts: 16557



WWW
« Reply #11 on: February 03, 2012, 10:01:34 PM »

Your error log show what's to be expected if you install a scenery after GSX. Until we update all the scenery installers, GSX or the Addon Manager must be installed last.

Reinstall GSX, and after it has been installed, try this:

Download the following file:
http://www.fsdreamteam.com/download/setup/bglmanx/6195/bglmanx.dll

and put it into the FSX root folder, overwriting the one that is already there and try if it works. If it doesn't, try with this one:
http://www.fsdreamteam.com/download/setup/bglmanx/bglmanx.dll
Logged

kbutterfield
Newbie
*
Posts: 26


« Reply #12 on: February 03, 2012, 10:28:01 PM »

Tried both files. No luck.

Kyle
Logged
virtuali
Administrator
Hero Member
*****
Posts: 16557



WWW
« Reply #13 on: February 03, 2012, 11:31:47 PM »

Tried both files. No luck.

Please, clarify this:

After reinstalling GSX AND trying replacing the files with the one I've linked, you have the Addon Manager menu, the Couatl menu, only one of them (which one ?) or none at all ?
Logged

kbutterfield
Newbie
*
Posts: 26


« Reply #14 on: February 04, 2012, 12:32:24 AM »

I have both menu's.  The add on manager which let's me see the products installed. It works.  I also have the other menu with the 3 choices, check for update, key mappings and restart, but none of those options work when you click on them. The most important thing is that the buildings at the airports are gone.

Kyle
Logged
Pages: [1] 2 3 4
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!