Author Topic: latest version and system requirement  (Read 5023 times)

hugh

  • Newbie
  • *
  • Posts: 1
latest version and system requirement
« on: July 22, 2011, 07:12:55 am »
Hi
I purchased the CD version 1.0 of X Class World on 4/29/2010.  How can I find if there are any updates to that version since then?

I also note that the readme file says that this software is for FSX and windows XP only.  Does that mean I will have problems if I install it on my Windows 7x64 system?  If so is there an updated version for newer systems?

Hugh

virtuali

  • Administrator
  • Hero Member
  • *****
  • Posts: 43171
    • VIRTUALI Sagl
Re: latest version and system requirement
« Reply #1 on: July 22, 2011, 10:19:04 am »
I purchased the CD version 1.0 of X Class World on 4/29/2010.  How can I find if there are any updates to that version since then?

There aren't, the CD includes all the latest version of all XClass products released so far.

Quote
I also note that the readme file says that this software is for FSX and windows XP only.  Does that mean I will have problems if I install it on my Windows 7x64 system?  If so is there an updated version for newer systems?

The readme was of course written way before Windows 7 was released so, it couldn't know about future OS. However, all products sold here works fine with Windows 7 x64. We all use Windows 7 x64 when testing.