Author Topic: Switzerland mesh causing frequent shuttering  (Read 946 times)

psiep

  • Newbie
  • *
  • Posts: 1
Switzerland mesh causing frequent shuttering
« on: August 27, 2022, 11:35:13 pm »
- Bought Swiss mesh from MS store in August 2021.  No problems with any flights.
- Upgraded to v1.1.1.1 afterward
- Shuttering occurred while flying Asobo A320 over the Alps to land (still shuttering) at LIPZ in August 2022
- Shuttering stops after de-installing the mesh.

Hope you guys can get it fixed.

virtuali

  • Administrator
  • Hero Member
  • *****
  • Posts: 46895
    • VIRTUALI Sagl
Re: Switzerland mesh causing frequent shuttering
« Reply #1 on: August 27, 2022, 11:57:13 pm »
We don't know how to fix it, the scenery is fully SDK compliant and has been compiled with the MSFS own tool, and it's an officially supported and documented type of scenery. It always worked perfectly fine until a certain sim update, and nowhere in the SDK there is any indication we should change something or do something any differently to support possible changes in the simulator.

The only generic answer we got from Asobo, is those kind of scenery objects weren't supposed to do entire countries, which doesn't explain why it worked perfectly fine before but there are no alternative in the SDK, and the only unofficial alternative (the .CGL file format) doesn't have any official tools and can't be used to do small countries bordering several other countries, because the minimum size of a scenery made with using the .CGL mesh format is way larger than the entire Switzerland, and it will surely conflict with other mesh from nearby countries.

We *suspect* that, the simulator is trying to load two meshes at once, the default one and the custom one, instead of just taking data from the one of higher priority or higher quality and, after the default mesh in the area got an increase in resolution with the Switzerland update, it's possible the simulator just can't keep up with all that data.

Some users reported a marked decrease in stuttering by switching the audio device in the sim, then switching it back again, before every flight. This kind of solution leads to believe there's some kind of bug related to handling of memory and/or resources as well, which might be cleaned up in some way when triggered by an audio device change.

mmcmah

  • Newbie
  • *
  • Posts: 26
Re: Switzerland mesh causing frequent shuttering
« Reply #2 on: September 11, 2022, 12:04:14 am »
I had the 10m scenery installed and the stutters were practically constant. It was completely unusable!

I tried the 20m scenery and the stutters were less frequent, but still very bothersome and I was on the verge of uninstalling the scenery (despite the fact that I am ever the optimist and hope that SU10 coming out next week will help solve the underlying problem(s)).

With that said, I am tending to agree with Umberto that there is something going on with the system, either because of the way it treats these kinds of files, or because of some other instability that was introduced.

I tried out the solutions in these two responses from the same thread. I need to try it out more, and the stutters are not fully gone, but the experience is MUCH better. Personally, I will now be more confident to wait and see how it goes with SU10.

Easy to try and doesn't take long:
https://www.fsdreamteam.com/forum/index.php/topic,25471.msg171674.html#msg171674

I have Task Manager running on another monitor and although I follow the instructions and end the task, it pops back up immediately (it doesn't seem to disappear, actually):
https://www.fsdreamteam.com/forum/index.php/topic,25471.msg172491.html#msg172491

Both seem to have a positive effect on reducing stutters. YMMV, but worth trying.

mmcmah

  • Newbie
  • *
  • Posts: 26
Re: Switzerland mesh causing frequent shuttering
« Reply #3 on: September 11, 2022, 06:51:36 am »
I tried the solutions I referenced above on an actual flight. They help, but there are still tons of stutters using the 10m mesh. I'll leave it for now, but if SU10 doesn't eliminate whatever bug exists, or FSDT can't come up with a workaround, then I'll have to uninstall the mesh.

mmcmah

  • Newbie
  • *
  • Posts: 26
Re: Switzerland mesh causing frequent shuttering
« Reply #4 on: September 21, 2022, 11:08:28 pm »
Thrilled to report that after the update to SU10 that was released today, the mesh, even the 10m one, is working flawlessly! Buttery smooth, actually.

I do think it was a bug that had to do with sound, and it seems to be resolved now. I am using DX11 and DLSS, but I don't think those matter for whatever was causing it to not work.
« Last Edit: September 21, 2022, 11:39:36 pm by mmcmah »