Author Topic: Can't register any of the products  (Read 86 times)

roodey

  • Newbie
  • *
  • Posts: 13
Can't register any of the products
« on: November 19, 2021, 04:17:34 pm »
Hello,

I keep having the same message when i start a flight, from any airport. "An unknown addon is causing COUATL to restart".  See log attached. I have installed fsdreamteam Geneva, Zurich, GSX + GSX lvl 2. I can't register  any of them. And when i can register them, the next time they aren't registered anymore.
The complete p3d folder and the complete addon manager folder are excluded from the virusscanner, as wel as the complete appdata folder.

I am doing a full install of p3d v4.5 on my new pc, currently i have ORBX Global, Vector and Europe installed, and about 60 airports. No payware aircraft or any texture addons yet.

Can you please help me? My sim experience is not the same without GSX...


Log:

couatl v4.0 (build 4585)
panic log started on Fri Nov 19 16:17:18 2021

problem raised by addon <unknown>
Traceback (most recent call last):
  File "<string>", line 48, in loadAddons
  File "<string>", line 37, in importAndCreateInstance
Couatl.DecryptionError: magic number mismatch
{}

Regards
Ruud



virtuali

  • Administrator
  • Hero Member
  • *****
  • Posts: 41920
    • VIRTUALI Sagl
Re: Can't register any of the products
« Reply #1 on: November 19, 2021, 04:52:50 pm »
That's not normal, it seems you are not getting all the latest files from the update, like some are new and some are old, which seems to be caused by the antivirus or the firewall blocking some files and allowing other.

- Configure the antivirus to exclude the whole Addon manager folder

- Be sure the firewall is not blocking access to the updater

- run the updater again.

roodey

  • Newbie
  • *
  • Posts: 13
Re: Can't register any of the products
« Reply #2 on: November 19, 2021, 05:46:24 pm »
Hello,

I allready exluded the entire addon manager folder from the firewall. However, in the Inbound Rules from Windows Defender, there were a few lines with Couatl. Some of them were not allowed inbound. Allowing them seemed to fix it. Very strange, since i checked that after every installation. But it works now, so thank you for the quick response!

Regards Ruud