FSDreamTeam forum
April 17, 2021, 12:56:18 PM *
Welcome, Guest. Please login or register.

Login with username, password and session length
News:
 
   Home   Help Login Register  
Pages: [1]
  Print  
Author Topic: Geneva LSGG huge latency loading the scenery  (Read 1666 times)
Agios
Newbie
*
Posts: 5


« on: January 05, 2021, 09:49:15 PM »

Hello to everybody! I have almost all FSDT sceneries in FS9 and they are GREAT!!! But LSGG has a very serious issue! The buildings of the airoport are missing till you go very very close and then they load! There are also other sceneris that has this issue even if they are medium or low quality or even if they are in FSDT's high quality! So, quality is not an issue... otherwise my system is powerfull enough without any performance problem! In other sceneries that I ve see the same issue the buildings load around 5-6 miles before landing or in some cases the whole scenery at once! In LSGG, the buildings near runway 5 load when I am around 10 miles before landing (that's ok) but the rest of the buildings missing and start to appear one by one after landing while taxing!!! The same issue appear also in other people that I have talked! I resized the textures but nothing changed, is obviously not a performance problem! Pobably, the problem has to do with the scenery's configuration that could have a solution with an easy update...
Logged
virtuali
Administrator
Hero Member
*****
Posts: 40841



WWW
« Reply #1 on: January 07, 2021, 02:30:59 PM »

The problem doesn't have anything to do with the scenery, and it doesn't happen, unless you change the "Compatibility" setting for the FS9.EXE, which is not how it is by default. With no compatibility tweaks ( default ), the problem doesn't happen.
Logged

Agios
Newbie
*
Posts: 5


« Reply #2 on: January 07, 2021, 05:59:51 PM »

The problem doesn't have anything to do with the scenery, and it doesn't happen, unless you change the "Compatibility" setting for the FS9.EXE, which is not how it is by default. With no compatibility tweaks ( default ), the problem doesn't happen.


Please, can you be more speciefic? I didnt change anything in FS9.exe
Logged
virtuali
Administrator
Hero Member
*****
Posts: 40841



WWW
« Reply #3 on: January 09, 2021, 03:30:28 PM »

Please, can you be more speciefic? I didnt change anything in FS9.exe

Sometimes Windows changes that setting automatically, especially after a crash, trying to "help" you running better. Right-click on FS9.EXE, and be sure nothing is enabled in the "Compatibility" tab of the file Properties.
Logged

Agios
Newbie
*
Posts: 5


« Reply #4 on: January 09, 2021, 09:13:19 PM »

Please, can you be more speciefic? I didnt change anything in FS9.exe

Sometimes Windows changes that setting automatically, especially after a crash, trying to "help" you running better. Right-click on FS9.EXE, and be sure nothing is enabled in the "Compatibility" tab of the file Properties.


Ok I checked my FS9.exe and nothing is enabled in "Compatibility" tab, but the problem with LSGG remains!
Logged
Agios
Newbie
*
Posts: 5


« Reply #5 on: January 10, 2021, 03:08:46 PM »

Please, can you be more speciefic? I didnt change anything in FS9.exe

Sometimes Windows changes that setting automatically, especially after a crash, trying to "help" you running better. Right-click on FS9.EXE, and be sure nothing is enabled in the "Compatibility" tab of the file Properties.


I noticed something else! I always fly with 50% zoom! If I fly with 100% zoom then buildings apear earlier, not so late like 50% zoom! But is the ONLY ONE scenery that has this problem! Ofcourse is better to fly with 50% zoom to have wider view and more crispe textures! What we can do for that? Please!!!
Logged
virtuali
Administrator
Hero Member
*****
Posts: 40841



WWW
« Reply #6 on: January 10, 2021, 06:19:35 PM »

I noticed something else! I always fly with 50% zoom! If I fly with 100% zoom then buildings apear earlier, not so late like 50% zoom! But is the ONLY ONE scenery that has this problem

This is not "a problem". This is called LOD and, fact this is the "only one" scenery that has this "problem" ( which is not a problem ), it's because not many sceneries use LOD to optimize fps, because it takes extra effort to do it so, most developers simply don't bother.

LOD is dependent on a combination of your screen resolution and your zoom setting so, the less resolution you have, the earlier the objects will disappear, since the values are calculated from the size of an object in Pixel on your screen, not its distance from the observer.

Quote
Of course is better to fly with 50% zoom to have wider view and more crispe textures!

Of course not. Using wider zoom to increase the resolution it's just wrong, the proper way to get sharper textures is to use Anisotropic filtering and, by flying at 50% zoom, you are altering the perspective and the relationship between far/close objects.

It's commonly accepted that, in FS9 or FSX, the most realistic zoom that matches what you would see in a real cockpit without altering the real perspective it's around 70-75%, so we usually optimized our sceneries for that.
Logged

Agios
Newbie
*
Posts: 5


« Reply #7 on: February 25, 2021, 07:20:43 PM »

I try to change some LOD setting to FS9.cfg but nothing changed! The problem starts at 93% zoom... Too sad for a nice scenery like this!
Logged
agent00729
Newbie
*
Posts: 4


« Reply #8 on: March 12, 2021, 01:31:06 AM »

Iím also having this same issue! I have all the fs9 sceneries except LAX, and this is the only one with this issue. The buildings donít appear and are all flat black squares on the ground until you get close. Any way to fix this?
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2015, Simple Machines Valid XHTML 1.0! Valid CSS!