FSDreamTeam forum
April 03, 2020, 02:58:38 AM *
Welcome, Guest. Please login or register.

Login with username, password and session length
News:
 
   Home   Help Login Register  
Pages: 1 [2]
  Print  
Author Topic: Couatl has stopped loading **SOLVED**  (Read 1030 times)
srcooke
Jr. Member
**
Posts: 69


« Reply #15 on: February 13, 2020, 01:05:52 PM »

Ok, this is interesting and worth checking for. It *might* be related to reading some parameters from the aircraft.cfg. Could you please try to use your standard language and, instead, only change the decimal separator from comma to dot ?

Having reinstated English UK and changed the decimal separator from comma to period couatl loaded seven out of ten times.
Logged

Regards
Stephen Cooke
virtuali
Administrator
Hero Member
*****
Posts: 37943



WWW
« Reply #16 on: February 13, 2020, 01:30:01 PM »

Having reinstated English UK and changed the decimal separator from comma to period couatl loaded seven out of ten times.

Which airport you were on ? As explained in other posts, if the airport has many GSX jetways, you should be sure all of them have been recreated, before switching airplane or manually restart Couatl. If you don't do that, we'll never know if the issue is really related to language setting, decimal separator, or just not waiting enough between a restart.
Logged

srcooke
Jr. Member
**
Posts: 69


« Reply #17 on: February 13, 2020, 01:34:43 PM »

LEMG and on each occasion I directly loaded from the sim front screen, so no changing aircraft or asking couatl to reload.

The sim was restarted between each of the ten loads.
Logged

Regards
Stephen Cooke
virtuali
Administrator
Hero Member
*****
Posts: 37943



WWW
« Reply #18 on: February 13, 2020, 01:44:09 PM »

The sim was restarted between each of the ten loads.

Have you waited enough between restarting the sim ? A common mistake is thinking that just because the simulator icon has gone from the Taskbar, you can start it again.

That's not how it works, the simulator executable is still closing and, more importantly, it has sent a command to all loaded external .EXE to close, and they will take their own additional time to close and close all the open handles to files, and this will prevent them to start on the next run.

If you want to have a feel how much you should wait on your system, open the GSX Control Panel when the simulator is running, and note how much it takes for the "Compile" button to become available. That's when it's really safe to restart the sim again. Try the same test using this method.
Logged

YG_FDE
Newbie
*
Posts: 3


« Reply #19 on: February 14, 2020, 01:26:11 AM »

I think I nailed the problem down to the time format settings in the Windows Regions. After many tests today it seems that only those regions are affected that have a 24 hour clock system and also have the AM and PM symbol appearing in the settings window. If you open the advanced region settings in Win and go to the 3rd tab (time) there are four settings (see attachment).

Example for UK:
Short time: HH:mm
Long time: HH:mm:ss
AM Symbol: AM  --> delete "AM" for a 24 hour clock system
PM Symbol: PM  --> same as above with "PM"

If the 24 hour clock system is used, the time format starts with a capital H. The fields of AM and PM Symbol must then be empty or Couatl will crash. But in the default region settings for English (UK), German (Switzerland and Austria) and probably many others, the two symbol fields contain the words "AM" and "PM" despite the 24 hour system. I think this is a wrong behaviour of Windows.
For other regions such as German (Germany) or French (France) the fields are correctly empty by default. The US region is also correct as it actually references AM and PM in the time format (hh:mm:ss tt). For a crosscheck I set in the US region the "long time" format to the same as the UK and the crashes then appeared too. The "short time" worked with 12 and 24 hours, regardless of the AM/PM symbols, the "long time" is critical.

After deleting the words "AM" and "PM", I could not produce a Couatl crash so far (>40 reloads instead of max 6-7). Can anyone test this as well?

Yves


* Time-settings.PNG (29.21 KB, 661x935 - viewed 65 times.)
Logged
virtuali
Administrator
Hero Member
*****
Posts: 37943



WWW
« Reply #20 on: February 14, 2020, 10:25:28 AM »

Quote
But in the default region settings for English (UK), German (Switzerland and Austria) and probably many others, the two symbol fields contain the words "AM" and "PM" despite the 24 hour system. I think this is a wrong behaviour of Windows.

This is REALLY weird, and it's definitely a Windows bug. I tried the 3 different settings for Italian, and 2 of them are wrong:

- Italian ( Switzerland ) 24 Hours with AM/PM set ( WRONG )
- Italian ( San Marino ) 24 Hours with AM/PM set ( WRONG )
- Italian ( Italy ) 24 Hours with AM/PM clear ( CORRECT )

German and French is similarly wrong, since German ( Switzerland ) and French ( Switzerland ) both have 24 H and AM/PM, while German ( Germany ) and French ( France ) are correct.

As far as I know, all Europe except the UK use plain 24 Hours format with no AM:PM.

After deleting the words "AM" and "PM", I could not produce a Couatl crash so far (>40 reloads instead of max 6-7). Can anyone test this as well?

Ok, that was useful, could you please try Live Update, and set the time format to be in the "wrong" format again, and see if it's works better now ?

There's nothing in our own code that should have an issue with that, but it *might* confuse the QLM/Soraco licensing system we use, since it surely must check dates, when comparing the user time against the activation server time, so we just uploaded a new executable that use a slightly newer version of that library.

They update it very often, but we don't always put the latest version in every update, otherwise it would force us to update Couatl.exe almost weekly, and that would cause other problems with some antivirus, blocking it just because "it's new". Let's hope they don't do it now...
« Last Edit: February 14, 2020, 10:54:15 AM by virtuali » Logged

srcooke
Jr. Member
**
Posts: 69


« Reply #21 on: February 14, 2020, 11:01:27 AM »

Thanks for the findings Yves, certainly having switched to English US I loaded successfully more than 30 times.

Umberto, I have restored the English UK region and ran live-update, will test throughout the day.
Logged

Regards
Stephen Cooke
Derek
Newbie
*
Posts: 6


« Reply #22 on: February 14, 2020, 11:31:58 AM »

Yes that new update has fixed the problem , great team work
Logged
keithgiannoni
Newbie
*
Posts: 34


« Reply #23 on: February 14, 2020, 03:04:10 PM »

Well done to Yves!!!! All good with me. You know after all these years of flight simulation, it never ceases to pop with a new previously unthought of odd problem! This also proves the power of a good Forum of members together with product support. Thanks to all for their efforts here. Now where shall we fly to today.....!

Keith
Logged
YG_FDE
Newbie
*
Posts: 3


« Reply #24 on: February 14, 2020, 06:27:44 PM »

Good to hear that it helped.  Smiley I can confirm that after running the Live Updater Couatl works fine even with the incorrect AM and PM settings. I tested English (UK) and German (Switzerland).

Yves
Logged
AlanJ
Newbie
*
Posts: 7


« Reply #25 on: February 20, 2020, 12:08:29 PM »

Thank you to everyone for working to solve this issue, all seems to be fine now!
Logged
Pages: 1 [2]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2015, Simple Machines Valid XHTML 1.0! Valid CSS!