FSDreamTeam forum
November 16, 2019, 02:03:35 AM *
Welcome, Guest. Please login or register.

Login with username, password and session length
News:
 
   Home   Help Login Register  
Pages: [1]
  Print  
Author Topic: Geneva 2.1.1 and Windows XP  (Read 233 times)
hwmertens
Newbie
*
Posts: 29


« on: October 09, 2019, 05:40:39 PM »

First at all, i am not a native english speaking/writing person.

I am running nowadays a total of 3 PCs mostly for the hobby of flightsimming built
at 2006, 2010 and 2018 with different flightsimulators e.g. FS2004, FSX SP2,
FSX Acceleration, P3Dv3 and operating systems (Windows XP SP, Windows 7 SP1 and Windows 10 Home).

The oldest one with a Core Duo E6600 @2.4GHz, Windows XP SP3 and FSX SP2 installed.

At late December 2014 I (re-)installed a bunch a Airports/Sceneries from FSDT on this PC.

Here is the actual list of products with version #s.
Code:
GSX         1.9.0.3
Hawaiian Apts 1 1.8.3
Hawaiian Apts 2 1.5.3
Honolulu 1.4.3
Houston         1.2
KJFK v2         2.3.3
KLAX         1.5.3
OhareX         2.3.5
Vancouver 1.4.1
All these addons were running smooth until yesterday, when i bought a license of Geneva at PC Aviator.

I repeatedly visited the website of FSDT and there is/was no sign that this very old rendition of Geneva
is/was ever updated to a newer one. So i liked to add it to my existing bunch of FSDT Sceneries.

But the installation of the downloaded version 2.1.1 forced me to install the latest version of GSX/GSXL2
which totally messed up my system not allowing even a good start of FSX SP2 anymore.

I managed to get FSX to start again but I can't even revert to GSX 1.9.0.3. which was originally installed
and running perfect before since there are no entries in the FSX Menu Addons for Couatl or Addon Manager any longer.

Help is really appreciated.

Hans
Logged
virtuali
Administrator
Hero Member
*****
Posts: 36640



WWW
« Reply #1 on: October 11, 2019, 04:57:14 PM »

I'm sorry, but our software doesn't support Windows XP anymore since several years.
Logged

hwmertens
Newbie
*
Posts: 29


« Reply #2 on: October 11, 2019, 05:16:09 PM »

But GSX v1.9.0.3 was installed and running on Windows XP SP3 since 2014 until some days ago when I tried to install the newly bought FSDT Geneva Scenery.

It seems to be a problem with bglmanx.dll (Version 3_1_0_1) which FSX SP2 seems to not 'like'. I have no backup of the running one that's really a pity.

No possibility of any files in your archive to try?

Regards Hans
Logged
virtuali
Administrator
Hero Member
*****
Posts: 36640



WWW
« Reply #3 on: October 11, 2019, 05:26:23 PM »

It's not a question of using an old installer, since Esellerate closed, you *must* use the latest version of the software, because it's the only one that can activate a product bought recently, which doesn't use Esellerate anymore.
Logged

hwmertens
Newbie
*
Posts: 29


« Reply #4 on: October 11, 2019, 06:34:54 PM »

But help me to understand why the long time running Addon Manager showed all products as installed AND active when no check with esellerate is possible any longer or is this check only essential at installation time and later on not.
To be clear I have not tried to install the recently bought Geneva sceneriy but the old GSX setup.exe (1.9.0.3). And all registry entries for the products are still there!
Logged
virtuali
Administrator
Hero Member
*****
Posts: 36640



WWW
« Reply #5 on: October 11, 2019, 07:11:14 PM »

Esellerate closed its activation servers last week, but we were already selling products using the new activation system since July so, anything recently purchased, cannot activated with an old version of the software.

And, after you'll change hardware, even your older purchase will stop working, since they relied on Esellerate activation, which is no more. But this is not a problem, since we uploaded all the old Esellerate serial numbers on the new server, so you will be able to activate there your old Esellerate serial number, but to do that, you need the latest version of the software, and that doesn't run on XP anymore.
Logged

hwmertens
Newbie
*
Posts: 29


« Reply #6 on: October 11, 2019, 10:42:36 PM »

To be clear, I did not change Hardware on that system for years and I did not install any new FSDT Product bought since July because trying to install Geneva stopped early.
Every old FSDT product was running smooth and steady until the 9th of october and now no FSDT product is running anymore.
I have far more than hundred different sceneries and addons installed on that system for FS2004 and FSX which was newly built-up with the appearance of the new FSX RTM in 2006. It's grown up with time and my life. I spent thousands of hours to keep this system up-to-date.
Logged
virtuali
Administrator
Hero Member
*****
Posts: 36640



WWW
« Reply #7 on: October 11, 2019, 11:09:33 PM »

To be clear, I did not change Hardware on that system for years and I did not install any new FSDT Product bought since July because trying to install Geneva stopped early.

I said "after you'll change hardware", future time. You asked to explain "why the long time running Addon Manager showed all products as installed AND active when no check with esellerate is possible any longer", and that's precisely why: it's BECAUSE you haven't changed your hardware.

But as soon you'll do that, you are going to need another activation from Esellerate, which you can't, since the Esellerate servers are no more, and the new activation servers requires the latest version of our software, which doesn't work on XP.

And, if you don't update the software (which doesn't work under XP), you will never be able to activate your recently purchased Geneva, because if you purchased it after July, you got a new non-Esellerate serial key, which cannot be activated with the old version of the software. Which is not even relevant, because (again) Esellerate servers are now gone.

Quote
Every old FSDT product was running smooth and steady until the 9th of october and now no FSDT product is running anymore.

That's because you installed Geneva, which comes with all our latest software, so it's normal nothing will run anymore, since the current version of our software doesn't work with Windows XP.

Quote
I spent thousands of hours to keep this system up-to-date.

?? really, then why you use an outdated OS ? Windows 7 will be officially unsupported in January, you are two generations behind what will be the next OS to be retired!

I'll try to make it more clear:

- The ONLY way to continue to use your old purchases, is to use OLD installers (which we don't have anymore) and never change hardware, ever.

- The ONLY way to activate a recent purchase that came with a non-Esellerate serial key, is to use the latest software, which doesn't work in XP.

Really, you must update your OS, or you will soon find yourself unable to use any FSDT products you had.
Logged

hwmertens
Newbie
*
Posts: 29


« Reply #8 on: October 12, 2019, 11:18:28 AM »

Quote
- The ONLY way to continue to use your old purchases, is to use OLD installers (which we don't have anymore) and never change hardware, ever.
And that is exactly what I did. I have an old installer for gsx (1.9.0.3). But without success.
Logged
virtuali
Administrator
Hero Member
*****
Posts: 36640



WWW
« Reply #9 on: October 12, 2019, 02:42:31 PM »

And that is exactly what I did. I have an old installer for gsx (1.9.0.3). But without success.

You'll probably have to install it without a network, but we cannot possibly support you here, nobody can possibly test such old version, let alone with Windows XP. And of course, the moment you install the current Geneva, it will install the updated software, which would be the only way to be able to activate it, but not under XP.
« Last Edit: October 12, 2019, 02:44:08 PM by virtuali » Logged

hwmertens
Newbie
*
Posts: 29


« Reply #10 on: October 13, 2019, 04:21:56 PM »

The guess with trying to re-install Offline hit the target though it was a bit of a trial-and-error to find the installer which was at least stable.

From my saved installers at first I tried gsx_fsx_setup_v1903.exe which brought back the Addon Manager and Couatl to the FSX menu, but FSX SP2 terminated after about 30 seconds without any error. It just disappeared.

Then I tried 1.9.0.12 which ended up the same, but with the installer 1.9.0.9 FSX is running stable. Sometimes I have to restart Couatl, but don't know why and when. And there are some problems with other Addons like FSCopilot or SODE. I really don't know which one and why.

When I start FSX without a network connection Addon Manager and Couatl are there and I then can even reconnect.

I had to re-activate all the installed sceneries but that was no problem to enter the Serial Keys in again. Hawaiin Airports 2 was corrupted but I could re-install it.

I made two flights from KLAX to KSFO and from PHTO to PHNL in a Wilco Embraer 190 and could both terminate without any problems so far.

I think I can now live with the situation and send this ancient system to the background again, activating it from time to time. There are more systems to manage here Wink.

I am so grateful that you stick with me and my problems. Thank you so much.

Best Regards
Hans
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2015, Simple Machines Valid XHTML 1.0! Valid CSS!