FSDreamTeam forum
January 24, 2019, 03:53:05 AM *
Welcome, Guest. Please login or register.

Login with username, password and session length
News:
 
   Home   Help Login Register  
Pages: [1]
  Print  
Author Topic: Couatl problem won't go away **SOLVED**  (Read 217 times)
mush1960
Newbie
*
Posts: 16


« on: January 03, 2019, 05:51:20 PM »

I have just reloaded my LSGG software. The latest (I presume) addonmanager/couatl/etc. came with it, and I loaded gsx_level2 as instructed. I still get errors and Couatl dies. The error log says:

couatl v3.2 (build 4061)
panic log started on Thu Jan  3 16:44:42 2019

problem raised by engine or unspecified addon
{'Airport': 'LSGG', 'User Pos': (46.22360765953117, 6.095123095449695, 431.167 m, 1.09464 m, 307.2413550188409)}
Error: exception CREATE_OBJECT_FAILED in call AICreateSimulatedObject param #1 'LSGG_set01_3d'
{'Airport': 'LSGG', 'User Pos': (46.22360765953117, 6.095123095449695, 431.167 m, 1.09464 m, 307.2413550188409)}

Can you help please? I have read some of the other comments here, and checked for missing .bgl files, the seem to be there. What else can I do?

I should add that I get no  airport buildings or jetways. Runway and taxiway markings are present.
« Last Edit: January 07, 2019, 11:37:14 AM by virtuali » Logged
virtuali
Administrator
Hero Member
*****
Posts: 33261



WWW
« Reply #1 on: January 04, 2019, 11:17:26 AM »

The problem is not caused by LSGG, GSX or Couatl but, instead, is likely caused by your FSX.CFG (assuming you use FSX, since you don't say) being corrupted or reset, possibly by another addon, so now it's missing the line added by our installers to let it find the scenery objects.

If you or another utility reset or recreate the FSX.CFG, you must reinstall ALL (not just FSDT's) products that needs their path to find objects added as simobjectpaths = xxxx lines in the FSX.CFG

So, normally, a reinstall of any FSDT product should fix this, because our installers will of course add the required lines to the FSX.CFG file automatically but, you should try to identify why you FSX.CFG was reset, otherwise the problem will happen again.

Note that, while our installer will surely fix a missing line of a clean file, it won't touch a corrupted file so, you might have to fix it yourself, as explained here:

http://www.fsdreamteam.com/forum/index.php/topic,18592.msg129134.html#msg129134
Logged

mush1960
Newbie
*
Posts: 16


« Reply #2 on: January 04, 2019, 01:51:35 PM »

Yes, I am using FSX, FSX:SE to be exact. This is what is in my fsx_se.cfg for Simobjects:
SimObjectPaths.0=SimObjects\Airplanes
SimObjectPaths.1=SimObjects\Rotorcraft
SimObjectPaths.2=SimObjects\GroundVehicles
SimObjectPaths.3=SimObjects\Boats
SimObjectPaths.4=SimObjects\Animals
SimObjectPaths.5=SimObjects\Misc
SimObjectPaths.6=C:\Program Files (x86)\12bPilot\SODE\data\SimObjects
SimObjectPaths.7=C:\ProgramData\12bPilot\SODE\SimObjects

What do you suggest is missing/incorrect? The paths for 6 and 7 are correct, I have checked that. On the post you referred to, the .cfg file there included the path: SimObjectPaths.7=C:\Program Files (x86)\Addon Manager\Simobjects\Misc. I do not have that path, as you can see. I also do not have that file structure - C:\Program Files (x86)\Addon Manager is practically empty, it seems to have only uninstall info.
Logged
mush1960
Newbie
*
Posts: 16


« Reply #3 on: January 04, 2019, 02:13:00 PM »

OK, I seem to have fixed it. As I commented above, the path and structure SimObjectPaths.7=C:\Program Files (x86)\Addon Manager\Simobjects\Misc was missing. Scanning through my other folders, I found what looked like the correct file structure elsewhere. I copied it to the correct location, and modified the fsx_se.cfg file accordingly, and it now seems to work. Thanks for the hints.
Logged
mush1960
Newbie
*
Posts: 16


« Reply #4 on: January 11, 2019, 12:57:01 PM »

Okay, looks like I spoke too soon. Just to recap: I had purchased LSGG and also loaded the trial version of GSX to see what it looked like, with a view to buying the full package if it looked good. The  buildings at LSGG would not display, I just got dark shadows on the ground; runway markings and so on were fine. Couatl would not run, kept crashing. After the initial queries here, I did some copying around of  files and managed to get the scenery to appear. Couatl seemed to be fine. When I tried GSX, I was able to summon the ground services vehicles successfully. Then I tried to test the arrival features. I spawned at the end of the runway, taxied to one of the runway exist, hit CTL+SHIFT+F12 to get the menu up, and selected a stand with APIS and asked for a Follow Me vehicle. Nothing happened. I tried to get the menu up again, and it wouldn't appear. I decided to taxy in without the Follow Me, and found the APIS did  not work as I approached the stand, and neither did the jetty move. Obviously, something was still wrong. I decided to bite the bullet and do a clean start. I uninstalled LSGG and GSX, deleted all the files and folders that I knew about, rebooted my PC and then reinstalled them all. Now, I am back where I started, in that the LSGG buildings are not loading. When I try to pull up the menu, I get the "Warp to a trial airport" interaction. The reinstall was all done to the default filepaths. I am using FSX:SE and Windows 7. Can you advise? In addition, the folder c:\ProgramData\12bPilot\SODE\SimObjects is empty - is that correct?
Logged
mush1960
Newbie
*
Posts: 16


« Reply #5 on: January 11, 2019, 02:11:29 PM »

Update: After repeated removals and reinstalls of LSGG and GSX, I have got back to the stage where I can see the airport buildings. On arrival, I can request a stand with APIS and a Follow Me, but nothing happens after that. I get no messages about anything crashing, but I get no Follow Me, and cannot request the menus again. If I reset Couatl and taxy to the gate on my own, the APIS is not working and the jetty won't operate.
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2015, Simple Machines Valid XHTML 1.0! Valid CSS!