FSDreamTeam forum
September 28, 2020, 09:02:25 PM *
Welcome, Guest. Please login or register.

Login with username, password and session length
News:
 
   Home   Help Login Register  
Pages: [1]
  Print  
Author Topic: KMEM native P3D update  (Read 11902 times)
virtuali
Administrator
Hero Member
*****
Posts: 39652



WWW
« on: December 06, 2016, 04:24:13 PM »

We made an update for KMEM, converting many objects from the FSX SDK, to the latest P3D 3.0 SDK, which will greatly increase the smoothness of flight, since a lot of handling we had to do manually to support the background with advanced materials in FSX, is not needed in P3D anymore, when using the native P3D SDK.

The update is now included in the latest KMEM Full installer.
« Last Edit: February 02, 2017, 06:55:40 PM by virtuali » Logged

sfgiants13
Newbie
*
Posts: 7


« Reply #1 on: December 06, 2016, 09:09:29 PM »

I installed the update and everything is gone from the ground textures to the buildings at all FSDT airports.  I can't pull up the youdecide menu either.  Once I reinstall the addon manager everything goes back to normal.  I'm running the latest version of P3D.
Logged
dgraham1284
Newbie
*
Posts: 5


« Reply #2 on: December 06, 2016, 09:20:52 PM »

Same:


couatl v3.1 (build 3536)
panic log started on Tue Dec 06 14:21:28 2016

problem raised by addon <unknown>
Traceback (most recent call last):
  File "couatl\GSX\assistanceServices\jetwayOperations.py", line 77, in _checkParkingsWithJetways
  File "couatl\common\rwsl.py", line 191, in __init__
  File "couatl\KMEM\__init__.py", line 1122, in onAppStart
TypeError: __init__() got an unexpected keyword argument 'restartCouatl'
{'Airport': 'KMEM', 'User Pos': (35.02427504373341, -89.97552165761752, 107.966 m, 4.02955 m, 0.0)}
Logged
virtuali
Administrator
Hero Member
*****
Posts: 39652



WWW
« Reply #3 on: December 06, 2016, 09:53:12 PM »

Sorry guys, I missed an important piece of information: this update REQUIRES the GSX Public Beta here:

http://www.fsdreamteam.com/forum/index.php/topic,14631.0.html
Logged

dgraham1284
Newbie
*
Posts: 5


« Reply #4 on: December 06, 2016, 10:42:30 PM »

I am using the GSX beta.
Logged
virtuali
Administrator
Hero Member
*****
Posts: 39652



WWW
« Reply #5 on: December 07, 2016, 02:09:15 AM »

I am using the GSX beta.

No, you aren't:

Quote
couatl v3.1 (build 3536)

Your log shows you are using the standard release. You probably have installed something else from FSDT (apart this patch), after the Beta and this has reverted your Beta to non-Beta, because the regular installers downloads files, and the downloaded files, which are NON-Beta, always take precedence over anything else. The Beta installer, instead, runs entirely offline.

So, in order to restore the Beta, you must install the GSX Beta as the LAST thing you do. If you need to reinstall another FSDT product for any reason, you have to reinstall the GSX Beta after it, otherwise you'll roll back the Beta changes.
Logged

dgraham1284
Newbie
*
Posts: 5


« Reply #6 on: December 07, 2016, 02:13:10 AM »

Thanks, I sorted it.  I had reinstalled addon manager which restored it as you stated.
Logged
gianlucaballoni
Newbie
*
Posts: 11


« Reply #7 on: December 21, 2016, 01:11:09 AM »

Hi,
install this update, start sim and i have error coautl...
Update AddonManager (reinstall without uninstall other version), and now the scenery works well.
Don't install any GSX (no beta, no old version).
Logged
virtuali
Administrator
Hero Member
*****
Posts: 39652



WWW
« Reply #8 on: December 21, 2016, 01:26:15 AM »

install this update, start sim and i have error coautl...

Quote
Don't install any GSX (no beta, no old version).

NOW the Beta is no longer Beta, the patch doesn't require the full GSX Public Beta anymore, and the Stand Addon Manager it's enough. I'll update the post.

However, using KMEM without GSX doesn't really make much sense, since you'll lose all the jetways (which are created by GSX together with SODE), and since GSX is free to use at all FSDT airports, there are no reasons not to install it.
« Last Edit: December 21, 2016, 01:38:07 AM by virtuali » Logged

jscarano
Newbie
*
Posts: 5


« Reply #9 on: December 21, 2016, 10:35:30 PM »

Thanks so much for this update.
Logged
B777ER
Sr. Member
****
Posts: 341


« Reply #10 on: December 31, 2016, 10:27:53 PM »

Just tried MEM with this P3D update. Night and day on smoothness and performance. So so much better now. Great job. I hope you enact this procedure going forward with CLT, SDF, etc.... Don't let that old FSX cripple the scenery!
Logged

Eric
virtuali
Administrator
Hero Member
*****
Posts: 39652



WWW
« Reply #11 on: January 03, 2017, 06:32:27 PM »

I hope you enact this procedure going forward with CLT, SDF, etc.... Don't let that old FSX cripple the scenery!

Sure, and we'll probably do it for some of the older sceneries too.
Logged

Hnla
Hero Member
*****
Posts: 699



« Reply #12 on: January 03, 2017, 07:20:25 PM »

I notice no difference in performance
Logged
virtuali
Administrator
Hero Member
*****
Posts: 39652



WWW
« Reply #13 on: January 03, 2017, 07:35:32 PM »

I notice no difference in performance

You are not supposed to notice any difference in performances, if you mean fps. In fact, it's even possible you might notice a *slight* (almost not noticeable) fps loss, but you should see MUCH less stuttering.

Of course, if you didn't get much stuttering before, you wouldn't see much benefit either, because the stuttering weren't "caused" by KMEM entirely, they were also dependent on how many other addons sending Simconnect commands all at the same time you have installed so, no all users saw the same thing.

The P3D terrain textures made using the native P3D SDK simply allowed us to send *much* less Simconnect commands, and that's it.
Logged

Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2015, Simple Machines Valid XHTML 1.0! Valid CSS!