FSDreamTeam forum
December 14, 2019, 08:26:04 AM *
Welcome, Guest. Please login or register.

Login with username, password and session length
News:
 
   Home   Help Login Register  
Pages: [1]
  Print  
Author Topic: SODE problem found...Maybe  (Read 5162 times)
jimstiles
Jr. Member
**
Posts: 54


« on: June 09, 2016, 05:12:53 AM »

FSX-Steam

I have been trying to resove the same issues others have posted about......jetways not available, getting the message, don't forget to activate the jetway, etc..

I've tried everything suggested and even read the manual more than once. Tonight I reinstalled kmem and gsx to make sure everything was up to date. While reinstalling kmem, everything was going smooth until I got the small window called "SODE Platform Manager" where you click to register and activate SODE. I remember this windo from my first install but didn't notice until now that in the two top boxes, the paths showing are to my regular FSX, not the Steam version I'm installing to. I tried to change them but it won't let me, I can't delete whats in there.

Can someone verify that it should have the Steam path showing instead of the regular FSX? If so, how do I change them?

Thanks,
Jim
Logged
virtuali
Administrator
Hero Member
*****
Posts: 37016



WWW
« Reply #1 on: June 09, 2016, 02:47:25 PM »

Can someone verify that it should have the Steam path showing instead of the regular FSX? If so, how do I change them?

Have a look here:

http://www.fsdreamteam.com/forum/index.php/topic,13717.msg101647.html#msg101647

It seemed the OrbX installer changed the registry in some way, and this confused the GSX installer, so I guess it will confuse any other installer too.

If you have both FSX and FSX:SE installed the "Co-existance" key must be set to 1, otherwise it should be 0.
Logged

jimstiles
Jr. Member
**
Posts: 54


« Reply #2 on: June 09, 2016, 08:07:36 PM »

Ran the Regedit and found the value already set at 1, changed it to 0 just to change it in case something was hung up. Ran the KMEM install again but had the same paths showing in the platform manager window. Went back and reset it to 1, rebooted the computer then deleted the KMEM folder and tried the KMEM install again, still got the same regular paths to FSX. After closing that path window, I got a message saying "There was a problem updating some sceneries, please try again later."

I then clicked ok and it ran a short period then another notification window came up saying, "There was a problem updating some support files, please try again later."

Thanks
Logged
jimstiles
Jr. Member
**
Posts: 54


« Reply #3 on: June 10, 2016, 02:52:13 AM »

Ok, was able to finally get KMEM to reinstall without getting those two "problem updating" messages I mentioned but the platform manager window still shows the path to my regular FSX, I've checked the key using regedit and the Co-Existence value is at 1 which is where it was when I first checked it.

At least I can now continue to use KMEM, just not the jetways until I can figure out how to change those two paths in the platform manager.

Logged
jimstiles
Jr. Member
**
Posts: 54


« Reply #4 on: June 10, 2016, 03:28:18 PM »

I really don't want to delete my regular FSX yet as I haven't finished comparing it with the Steam version but unless someone knows a solution to changing the two paths in the platform manager, I may have to delete it to get everything working right on the Steam version. I've alerady checked the co-existence value and it was already set to a value of 1, at a loss what to check next.

Thanks for any help.

Jim
Logged
jimstiles
Jr. Member
**
Posts: 54


« Reply #5 on: June 12, 2016, 04:17:54 AM »

virtuali,

I thought I had found something on this problem, thought I'd get your thoughts on it.

I found this on the Steam Forum for Non-Steam Add-Ons. I tried making the changes for a dual install it suggested and it did change the Platform Installation Path in the Platform Manager window to the correct path but the 'exe.xml' and 'dll.xml' Path remained the same at C:\Users\AppData\Roaming\Microsoft\FSX.

I made the change mentioned and reinstalled KMEM and GSX, the Platform Manager window that came up while reinstalling KMEM had the change but it didn't make any difference, the jetway still didn't move. I loaded a 737 into Gate 27 which is on the GSX list of a /js jetway.

I don't know if the second line in the platform manager should have changed or not, the path I typed in above.

Here is what was said in this forum:

***********
Reg Edit Fix for those with old FSX & Steam FSX Installer bugs created.

The Dual Install of old FSX and FSX Steam Edition creates a bug for installers not updated to take it into account as they cannot locate the FSX Steam Folder and or it's User Folder FSX-SE with the fsx_se.cfg to adjust........ seems to be fixed for me with this simple Regedit:


1. Check your Windows Registry if you have one or both these keys:
HKEY_LOCAL_MACHINE\Software\Microsoft\Microsoft Games\Flight Simulator\10.0 (32-bit)
HKEY_LOCAL_MACHINE\Software\Wow6432Node\Microsoft\Microsoft Games\Flight Simulator\10.0 (64-bit)  (I HAD THIS ONE)

2. Check inside if SetupPath value points to your FSX:SE installation folder.
3. If that key or value does not exists, create it.
4. Otherwise, check if FSX:SE directory has permissions.


(I changed my key from C:\Program Files (x86)\Microsoft Games\Microsoft Flight Simulator X to G:\Program Files (x86)\Steam\steamapps\common\FSX

As my Steam in on G drive.

Now the paid and free FSX installers and programs work so far.
**********

In the above text copied from the forum, I have both located on my C: drive so that's what I used instead of his G drive letter.

 Any ideas or suggestions?    Thanks
Logged
virtuali
Administrator
Hero Member
*****
Posts: 37016



WWW
« Reply #6 on: June 12, 2016, 10:20:48 AM »

As I've said, we just launch the SODE installer as it is. No idea how it handles the registry keys or if it takes into account the co-existence key. Our installers do, but there's no interaction between our installation and the SODE installer that is being launched as part of the installer, meaning they don't share data about the found FSX.
Logged

12bpilot
Beta tester
Newbie
*****
Posts: 25


« Reply #7 on: June 12, 2016, 03:14:53 PM »

The SODE platform manager solely relies on (correct) registry entries to get the required paths. I have updated the application now to incorporate the Co-Existence key from a FSX:SE installation.
Thanks for testing (http://sode.12bpilot.ch/temp/SODEPlatformManager_12JUN16.zip)

If Co-Existence is set to 1, then the dll.xml and exe.xml should reside in Roaming/Microsoft/FSX-SE, if set to 0 it should point to Roaming/Microsoft/FSX.
Logged
jimstiles
Jr. Member
**
Posts: 54


« Reply #8 on: June 12, 2016, 06:51:30 PM »

Thanks 12bpilot,

I downloaded the file, unzipped it, and clicked on the application file, the Platform Manager window came up but it still shows the paths to the regular FSX.  I checked and my co-existence value is set at 1.

Did I do it right?

Thanks again
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2015, Simple Machines Valid XHTML 1.0! Valid CSS!