FSDreamTeam forum
June 04, 2020, 04:07:22 PM *
Welcome, Guest. Please login or register.

Login with username, password and session length
News:
 
   Home   Help Login Register  
Pages: [1]
  Print  
Author Topic: Cannot isntall GSX on P3Dv4.3 - Where are the legacy installs?  (Read 135 times)
smoothchat
Newbie
*
Posts: 8


« on: May 23, 2020, 06:42:04 AM »

I am migrating my flightsim setup to an upgraded PC.

I am using P3D4.3 and have too many addons that will have to be upgraded if I change to  4.4

The website will not allow me to download the older version of the installs so GSX is now no use to me.

Is there a location where I can download an older version of GSX?

Logged
Captain Kevin
Beta tester
Hero Member
*****
Posts: 538


Captain Kevin


« Reply #1 on: May 23, 2020, 09:40:19 AM »

Don't think so, but why would all those add-ons have to be upgraded if you change to 4.4. Bear in mind that 4.4 was the introduction of PBR, which a lot of add-ons are incorporating, so that's why at least 4.4 is required now.
Logged

Captain Kevin
smoothchat
Newbie
*
Posts: 8


« Reply #2 on: May 23, 2020, 03:24:15 PM »

Thanks Captain Kevin,

When a person builds a home cockpit (or a small resemblance of one) 90% of the effort is in getting everything working, and once achieved, not wanting to make any changes to the software mix.  This is why some people are still on FSX and even FS9!!

I am just wondering why FSDT don't provide access to older versions for people in that situation.

As it happens, I got things to work by copying various locations of my old PC, but having progressed thru several online updates, I didn't have a full installer of the last version before 4.4.

I have the same issue with PMDG who's auto updater now simply says that my version of the 737 is too old to update to the last release before the 737NGXu. I had to do the same old install/overwrite with a newer backup trick to get it working.

Cheers
Logged
Captain Kevin
Beta tester
Hero Member
*****
Posts: 538


Captain Kevin


« Reply #3 on: May 24, 2020, 03:44:15 AM »

With the number of times that GSX gets updated, it would be difficult and time consuming to still be able to support some of the older stuff, having to figure out which would work with 4.4 and which wouldn't. You'd more or less have to do double the work. A lot of developers now have dropped support for FSX and 32-bit programs because there are some things you can do in a 64-bit simulator that you can't do with a 32-bit simulator without increasing the risk of running out of memory for the 32-bit simulator. At some point, you're being held back too much by the limitations to be able to continue development for it. As for PMDG, if you're getting the warning that it's too old to update, it just means you need to download the new installer, then uninstall what you had and re-install using the latest installer. That only happens if the update is large enough that the Operations Center can't handle it.
Logged

Captain Kevin
smoothchat
Newbie
*
Posts: 8


« Reply #4 on: May 24, 2020, 05:57:09 AM »

it just means you need to download the new installer, then uninstall what you had and re-install using the latest installer.

Thanks Kevin, it was the new installer that said my 737 was too old to update (even though I know there is a later version (pre-737NGXu).  I ended up pasting an older backup of the PMDG Operations Center into the Program Files (x86) folder and running that.

I figured that maybe I could just dig up my original purchase email with download link and re-download what might have been an updated version, but that link no longer works and from what I can see, PMDG offer no historical access to purchases in order to re-aquire the files.

I got it working tho, after a lot of fiddling
Logged
Captain Kevin
Beta tester
Hero Member
*****
Posts: 538


Captain Kevin


« Reply #5 on: May 24, 2020, 12:26:30 PM »

I figured that maybe I could just dig up my original purchase email with download link and re-download what might have been an updated version, but that link no longer works and from what I can see, PMDG offer no historical access to purchases in order to re-aquire the files.
Go to PMDG's website, scroll down, click sign in/register, log into your store account, and you should be able to get it from there.
Logged

Captain Kevin
virtuali
Administrator
Hero Member
*****
Posts: 38733



WWW
« Reply #6 on: May 27, 2020, 01:52:37 PM »

This post here explain why you cannot download a version that works in P3D pre-4.4

http://www.fsdreamteam.com/forum/index.php/topic,23618.msg157631.html#msg157631

No use repeating all of that here but, in general, you should make a point to those add-on developers who still haven't updated their products to support a P3D release, 18 months after it came out.
Logged

Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2015, Simple Machines Valid XHTML 1.0! Valid CSS!